use strict;
my $str = 'Some text will come here <a class="checkStatusNowLink" href="https://something.com" style="color: rgb(255, 255, 255); font-size: 17px;">Check Status</a>. Some text will come here <a href="#">Click</a> Some text will come here.';
my $regex = qr/class="checkStatusNowLink" href="([^"]+)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}