import re
regex = re.compile(r"class=\"checkStatusNowLink\" href=\"([^\"]+)")
test_str = "Some text will come here <a class=\"checkStatusNowLink\" href=\"https://something.com\" style=\"color: rgb(255, 255, 255); font-size: 17px;\">Check Status</a>. Some text will come here <a href=\"#\">Click</a> Some text will come here."
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")