$re = '/class="checkStatusNowLink" href="([^"]+)/';
$str = 'Some text will come here <a class="checkStatusNowLink" href="https://something.com" style="color: rgb(255, 255, 255); font-size: 17px;">Check Status</a>. Some text will come here <a href="#">Click</a> Some text will come here.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);