import Foundation
let pattern = #"class="checkStatusNowLink" href="([^"]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"Some text will come here <a class="checkStatusNowLink" href="https://something.com" style="color: rgb(255, 255, 255); font-size: 17px;">Check Status</a>. Some text will come here <a href="#">Click</a> Some text will come here."##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}