using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"19[5-9]\d|20[0-4]\d|2050";
string input = @"1990 - 2010
1990-2022
2050
2000
2049
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}