const regex = /19[5-9]\d|20[0-4]\d|2050/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('19[5-9]\\d|20[0-4]\\d|2050', '')
const str = `1990 - 2010
1990-2022
2050
2000
2049
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}