import Foundation
let pattern = #"19[5-9]\d|20[0-4]\d|2050"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1990 - 2010
1990-2022
2050
2000
2049
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}