package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`19[5-9]\d|20[0-4]\d|2050`)
var str = `1990 - 2010
1990-2022
2050
2000
2049
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}