#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=(?:\s|\.|_|\-|\+|\(|\[))(?:19[2-9]|20[0-2])\d(?=\s|$|\.|_|\-|\+|\)|\])"
Local $sString = "1919" & @CRLF & _
"1920" & @CRLF & _
"1999" & @CRLF & _
"2001" & @CRLF & _
"2029" & @CRLF & _
"2030" & @CRLF & _
"Mute 2018 1080p NF WEB" & @CRLF & _
"Mute.2018.1080p.NF.WEB" & @CRLF & _
"Mute_2018_1080p NF WEB" & @CRLF & _
"Mute-2018-1080p" & @CRLF & _
"Mute(2018)1080p" & @CRLF & _
"Mute[2018]1080p" & @CRLF & _
"Mute+2018+1080p" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")