#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*\\(\[.*?\]).[^\[]+(\[.*\])\\.*"
Local $sString = "X:\East\_Complete Downloads\[2ndfire]Haibane_Renmei[BD][1080p][Dual-Audio][AV1][10bit]\Haibane Renmei - S01E01 - Cocoon Dream.mkv"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")