using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*\\(\[.*?\]).[^\[]+(\[.*\])\\.*";
string input = @"X:\East\_Complete Downloads\[2ndfire]Haibane_Renmei[BD][1080p][Dual-Audio][AV1][10bit]\Haibane Renmei - S01E01 - Cocoon Dream.mkv";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}