import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*\\\\(\\[.*?\\]).[^\\[]+(\\[.*\\])\\\\.*";
final String string = "X:\\East\\_Complete Downloads\\[2ndfire]Haibane_Renmei[BD][1080p][Dual-Audio][AV1][10bit]\\Haibane Renmei - S01E01 - Cocoon Dream.mkv";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}