$re = '/^.*\\\\(\[.*?\]).[^\[]+(\[.*\])\\\\.*/m';
$str = 'X:\\East\\_Complete Downloads\\[2ndfire]Haibane_Renmei[BD][1080p][Dual-Audio][AV1][10bit]\\Haibane Renmei - S01E01 - Cocoon Dream.mkv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);