#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"[a-zA-Z]+ [0-9]{1,2}, [0-9]{4} [0-9]{2}(:[0-9]{2}){2}[^"]*""
Local $sString = "AuditReport" & @CRLF & _
"asdf" & @CRLF & _
"qwerty" & @CRLF & _
"asdf" & @CRLF & _
"name, id, logindate" & @CRLF & _
"experiment,182002, "July 31, 2022 20:00:00" bla bla bla" & @CRLF & _
"unit 1998,183065, "July 3, 2022 21:00:00"bla bla" & @CRLF & _
"asdf, 202065, "May 25, 2022 20:00:00"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")