using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[a-zA-Z]+ [0-9]{1,2}, [0-9]{4} [0-9]{2}(:[0-9]{2}){2}[^""]*""";
string input = @"AuditReport
asdf
qwerty
asdf
name, id, logindate
experiment,182002, ""July 31, 2022 20:00:00"" bla bla bla
unit 1998,183065, ""July 3, 2022 21:00:00""bla bla
asdf, 202065, ""May 25, 2022 20:00:00""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}