import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"[a-zA-Z]+ [0-9]{1,2}, [0-9]{4} [0-9]{2}(:[0-9]{2}){2}[^\"]*\"";
final String string = "AuditReport\n"
+ "asdf\n"
+ "qwerty\n"
+ "asdf\n"
+ "name, id, logindate\n"
+ "experiment,182002, \"July 31, 2022 20:00:00\" bla bla bla\n"
+ "unit 1998,183065, \"July 3, 2022 21:00:00\"bla bla\n"
+ "asdf, 202065, \"May 25, 2022 20:00:00\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}