$re = '/"[a-zA-Z]+ [0-9]{1,2}, [0-9]{4} [0-9]{2}(:[0-9]{2}){2}[^"]*"/m';
$str = 'AuditReport
asdf
qwerty
asdf
name, id, logindate
experiment,182002, "July 31, 2022 20:00:00" bla bla bla
unit 1998,183065, "July 3, 2022 21:00:00"bla bla
asdf, 202065, "May 25, 2022 20:00:00"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);