const regex = /"[a-zA-Z]+ [0-9]{1,2}, [0-9]{4} [0-9]{2}(:[0-9]{2}){2}[^"]*"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"[a-zA-Z]+ [0-9]{1,2}, [0-9]{4} [0-9]{2}(:[0-9]{2}){2}[^"]*"', 'gm')
const str = `AuditReport
asdf
qwerty
asdf
name, id, logindate
experiment,182002, "July 31, 2022 20:00:00" bla bla bla
unit 1998,183065, "July 3, 2022 21:00:00"bla bla
asdf, 202065, "May 25, 2022 20:00:00"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}