// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"[a-zA-Z]+ [0-9]{1,2}, [0-9]{4} [0-9]{2}(:[0-9]{2}){2}[^"]*""#).unwrap();
let string = "AuditReport
asdf
qwerty
asdf
name, id, logindate
experiment,182002, \"July 31, 2022 20:00:00\" bla bla bla
unit 1998,183065, \"July 3, 2022 21:00:00\"bla bla
asdf, 202065, \"May 25, 2022 20:00:00\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}