const regex = /\b\w\d{7}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\w\\d{7}\\b', 'gm')
const str = `http://photos.v3.torontomls.net/Live/photos/FULL/1/270/E3285270.jpg?20150812131646`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}