// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b\w\d{7}\b").unwrap();
let string = "http://photos.v3.torontomls.net/Live/photos/FULL/1/270/E3285270.jpg?20150812131646";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}