import re
regex = re.compile(r"\b\w\d{7}\b", flags=re.MULTILINE)
test_str = "http://photos.v3.torontomls.net/Live/photos/FULL/1/270/E3285270.jpg?20150812131646"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")