$re = '/\b\w\d{7}\b/m';
$str = 'http://photos.v3.torontomls.net/Live/photos/FULL/1/270/E3285270.jpg?20150812131646';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);