re = /\b\w\d{7}\b/m
str = 'http://photos.v3.torontomls.net/Live/photos/FULL/1/270/E3285270.jpg?20150812131646'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end