using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{8}-\d{4})_(.{1,})_avl\.properties_(\d{8}-\d{4})_(.{1,})_avl.properties_(\d{8})\.txt$";
string input = @"20160330-1136_brandproduct_avl.properties_20160330-1255_brandproduct_avl.properties_20160330.txt
20160330-1136_brandproduct_avl.properties_20160330-1255_brandproduct_avl.properties_20160330.txt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}