import re
regex = re.compile(r"(\d{8}-\d{4})_(.{1,})_avl\.properties_(\d{8}-\d{4})_(.{1,})_avl.properties_(\d{8})\.txt$", flags=re.MULTILINE)
test_str = ("20160330-1136_brandproduct_avl.properties_20160330-1255_brandproduct_avl.properties_20160330.txt\n"
"20160330-1136_brandproduct_avl.properties_20160330-1255_brandproduct_avl.properties_20160330.txt")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")