import Foundation
let pattern = #"(\d{8}-\d{4})_(.{1,})_avl\.properties_(\d{8}-\d{4})_(.{1,})_avl.properties_(\d{8})\.txt$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
20160330-1136_brandproduct_avl.properties_20160330-1255_brandproduct_avl.properties_20160330.txt
20160330-1136_brandproduct_avl.properties_20160330-1255_brandproduct_avl.properties_20160330.txt
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)