$re = '/(\d{8}-\d{4})_(.{1,})_avl\.properties_(\d{8}-\d{4})_(.{1,})_avl.properties_(\d{8})\.txt$/m';
$str = '20160330-1136_brandproduct_avl.properties_20160330-1255_brandproduct_avl.properties_20160330.txt
20160330-1136_brandproduct_avl.properties_20160330-1255_brandproduct_avl.properties_20160330.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);