const regex = /(\d{8}-\d{4})_(.{1,})_avl\.properties_(\d{8}-\d{4})_(.{1,})_avl.properties_(\d{8})\.txt$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{8}-\\d{4})_(.{1,})_avl\\.properties_(\\d{8}-\\d{4})_(.{1,})_avl.properties_(\\d{8})\\.txt$', 'mg')
const str = `20160330-1136_brandproduct_avl.properties_20160330-1255_brandproduct_avl.properties_20160330.txt
20160330-1136_brandproduct_avl.properties_20160330-1255_brandproduct_avl.properties_20160330.txt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}