import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*J(\\w))(?=.+Q\\1)(?=.*T\\1)(?=.*K\\1)(?=.*A\\1).*$";
final String string = "TD JD QD KD AD \n"
+ "AD KD QD JD TD \n"
+ "KD TD QD AD JD \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}