$re = '/^(?=.*J(\w))(?=.+Q\1)(?=.*T\1)(?=.*K\1)(?=.*A\1).*$/m';
$str = 'TD JD QD KD AD
AD KD QD JD TD
KD TD QD AD JD
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);