re = /^(?=.*J(\w))(?=.+Q\1)(?=.*T\1)(?=.*K\1)(?=.*A\1).*$/m
str = 'TD JD QD KD AD
AD KD QD JD TD
KD TD QD AD JD
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end