use strict;
my $str = 'TD JD QD KD AD
AD KD QD JD TD
KD TD QD AD JD
';
my $regex = qr/^(?=.*J(\w))(?=.+Q\1)(?=.*T\1)(?=.*K\1)(?=.*A\1).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}