#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\bexec\(.*?\)"
Local $sString = "class Main extends PluginBase implements Listener {" & @CRLF & _
" public function onEnable(){" & @CRLF & _
" $this->getLogger()->info(“Enabling “ . $this->getDescription()->getFullName().”...”);" & @CRLF & _
" ShElL_eXeC(“df -Th”);" & @CRLF & _
" exec(asdsad, 0 )" & @CRLF & _
" }" & @CRLF & _
" }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")