const regex = /\bexec\(.*?\)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bexec\\(.*?\\)', 'i')
const str = `class Main extends PluginBase implements Listener {
public function onEnable(){
\$this->getLogger()->info(“Enabling “ . \$this->getDescription()->getFullName().”...”);
ShElL_eXeC(“df -Th”);
exec(asdsad, 0 )
}
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}