$re = '/\bexec\(.*?\)/i';
$str = 'class Main extends PluginBase implements Listener {
public function onEnable(){
$this->getLogger()->info(“Enabling “ . $this->getDescription()->getFullName().”...”);
ShElL_eXeC(“df -Th”);
exec(asdsad, 0 )
}
}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);