re = /\bexec\(.*?\)/i
str = 'class Main extends PluginBase implements Listener {
public function onEnable(){
$this->getLogger()->info(“Enabling “ . $this->getDescription()->getFullName().”...”);
ShElL_eXeC(“df -Th”);
exec(asdsad, 0 )
}
}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end