package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\bexec\(.*?\)`)
var str = `class Main extends PluginBase implements Listener {
public function onEnable(){
$this->getLogger()->info(“Enabling “ . $this->getDescription()->getFullName().”...”);
ShElL_eXeC(“df -Th”);
exec(asdsad, 0 )
}
}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}