#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\"(.+)\"\s*\(([\w. ]+[0-9\s]+[:][\s0-9\-]+.*)\)"
Local $sString = ""jfaj dkfjdf, kdjfd,k lkdjfldkfj." (r 3:2) dfk;dk/ ld;kfdk/ d;flk;dfk/ a;fk;dlf/ ;fkdf;dlkf/" & @CRLF & _
"" & @CRLF & _
";dkf;/ kfd;f/ljfdljf. "dlkfj dlkfjdlj ldfjldfj lfdjfl, lkdjf." (dd 3:1) " & @CRLF & _
"" & @CRLF & _
""ldkfjdljf dlfkj"(dd 2:1)" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")