// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\"(.+)\"\s*\(([\w. ]+[0-9\s]+[:][\s0-9\-]+.*)\)"#).unwrap();
let string = "\"jfaj dkfjdf, kdjfd,k lkdjfldkfj.\" (r 3:2) dfk;dk/ ld;kfdk/ d;flk;dfk/ a;fk;dlf/ ;fkdf;dlkf/
;dkf;/ kfd;f/ljfdljf. \"dlkfj dlkfjdlj ldfjldfj lfdjfl, lkdjf.\" (dd 3:1)
\"ldkfjdljf dlfkj\"(dd 2:1)
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}