const regex = /\"(.+)\"\s*\(([\w. ]+[0-9\s]+[:][\s0-9\-]+.*)\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\"(.+)\\"\\s*\\(([\\w. ]+[0-9\\s]+[:][\\s0-9\\-]+.*)\\)', 'g')
const str = `"jfaj dkfjdf, kdjfd,k lkdjfldkfj." (r 3:2) dfk;dk/ ld;kfdk/ d;flk;dfk/ a;fk;dlf/ ;fkdf;dlkf/
;dkf;/ kfd;f/ljfdljf. "dlkfj dlkfjdlj ldfjldfj lfdjfl, lkdjf." (dd 3:1)
"ldkfjdljf dlfkj"(dd 2:1)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}