using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""(.+)\""\s*\(([\w. ]+[0-9\s]+[:][\s0-9\-]+.*)\)";
string input = @"""jfaj dkfjdf, kdjfd,k lkdjfldkfj."" (r 3:2) dfk;dk/ ld;kfdk/ d;flk;dfk/ a;fk;dlf/ ;fkdf;dlkf/
;dkf;/ kfd;f/ljfdljf. ""dlkfj dlkfjdlj ldfjldfj lfdjfl, lkdjf."" (dd 3:1)
""ldkfjdljf dlfkj""(dd 2:1)
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}