import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"(.+)\\\"\\s*\\(([\\w. ]+[0-9\\s]+[:][\\s0-9\\-]+.*)\\)";
final String string = "\"jfaj dkfjdf, kdjfd,k lkdjfldkfj.\" (r 3:2) dfk;dk/ ld;kfdk/ d;flk;dfk/ a;fk;dlf/ ;fkdf;dlkf/\n\n"
+ ";dkf;/ kfd;f/ljfdljf. \"dlkfj dlkfjdlj ldfjldfj lfdjfl, lkdjf.\" (dd 3:1) \n\n"
+ "\"ldkfjdljf dlfkj\"(dd 2:1)\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}