#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((b+.*)|((a(aa)*)?b*)|a*((bbb)*|bb(bbb)*)|(.*a+))$"
Local $sString = "aabbbb" & @CRLF & _
"aaaab" & @CRLF & _
"" & @CRLF & _
"aabb" & @CRLF & _
"" & @CRLF & _
"abbbb" & @CRLF & _
"aaabbbb" & @CRLF & _
"bbbb" & @CRLF & _
"" & @CRLF & _
"bbbb" & @CRLF & _
"bbbbb" & @CRLF & _
"bbbbbbb" & @CRLF & _
"" & @CRLF & _
"aa" & @CRLF & _
"aaaabb" & @CRLF & _
"aaaabbb" & @CRLF & _
"aaaabbbbb" & @CRLF & _
"" & @CRLF & _
"abbbb" & @CRLF & _
"baabbbb" & @CRLF & _
"aabbbba" & @CRLF & _
"aabbb" & @CRLF & _
"aa" & @CRLF & _
"bbbb" & @CRLF & _
"b" & @CRLF & _
"baaaa" & @CRLF & _
"baaba"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")