$re = '/^((b+.*)|((a(aa)*)?b*)|a*((bbb)*|bb(bbb)*)|(.*a+))$/m';
$str = 'aabbbb
aaaab
aabb
abbbb
aaabbbb
bbbb
bbbb
bbbbb
bbbbbbb
aa
aaaabb
aaaabbb
aaaabbbbb
abbbb
baabbbb
aabbbba
aabbb
aa
bbbb
b
baaaa
baaba';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);