const regex = /^((b+.*)|((a(aa)*)?b*)|a*((bbb)*|bb(bbb)*)|(.*a+))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((b+.*)|((a(aa)*)?b*)|a*((bbb)*|bb(bbb)*)|(.*a+))$', 'gm')
const str = `aabbbb
aaaab
aabb
abbbb
aaabbbb
bbbb
bbbb
bbbbb
bbbbbbb
aa
aaaabb
aaaabbb
aaaabbbbb
abbbb
baabbbb
aabbbba
aabbb
aa
bbbb
b
baaaa
baaba`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}