// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((b+.*)|((a(aa)*)?b*)|a*((bbb)*|bb(bbb)*)|(.*a+))$").unwrap();
let string = "aabbbb
aaaab
aabb
abbbb
aaabbbb
bbbb
bbbb
bbbbb
bbbbbbb
aa
aaaabb
aaaabbb
aaaabbbbb
abbbb
baabbbb
aabbbba
aabbb
aa
bbbb
b
baaaa
baaba";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}