using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((b+.*)|((a(aa)*)?b*)|a*((bbb)*|bb(bbb)*)|(.*a+))$";
string input = @"aabbbb
aaaab
aabb
abbbb
aaabbbb
bbbb
bbbb
bbbbb
bbbbbbb
aa
aaaabb
aaaabbb
aaaabbbbb
abbbb
baabbbb
aabbbba
aabbb
aa
bbbb
b
baaaa
baaba";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}