import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((b+.*)|((a(aa)*)?b*)|a*((bbb)*|bb(bbb)*)|(.*a+))$";
final String string = "aabbbb\n"
+ "aaaab\n\n"
+ "aabb\n\n"
+ "abbbb\n"
+ "aaabbbb\n"
+ "bbbb\n\n"
+ "bbbb\n"
+ "bbbbb\n"
+ "bbbbbbb\n\n"
+ "aa\n"
+ "aaaabb\n"
+ "aaaabbb\n"
+ "aaaabbbbb\n\n"
+ "abbbb\n"
+ "baabbbb\n"
+ "aabbbba\n"
+ "aabbb\n"
+ "aa\n"
+ "bbbb\n"
+ "b\n"
+ "baaaa\n"
+ "baaba";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}