using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(-\s*)";
string substitution = @"\n$1";
string input = @"To do list: - Buy milk - Feed cat";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}